Разработка урока по теме «Исполнитель Чертежник. Использование вспомогательных алгоритмов. Работа в среде Кумир»

Разделы: Информатика


Цели урока:

  • закрепить представления учащихся об исполнителях алгоритмов;
  • научить учащихся управлять исполнителем Чертежник с использованием вспомогательных алгоритмов;
  • сформировать умение записи, исполнения и отладки алгоритмов с использованием команд Чертежника в среде «Кумир»

Обеспечение урока:

  • система Кумир;
  • мультимедийный проектор;
  • презентация урока (приложение 1)
  • карточки-задания;
  • компьютеры.

Ход урока

1. Проверка домашнего задания.

  • Блиц-опрос учащихся на знание основных определений: исполнитель, формальный исполнитель, неформальный исполнитель.
  • Ученики приводят примеры неформальных и формальных исполнителей.

2. Объяснение нового материала.

Чертежнику часто приходится рисовать одно и тоже несколько раз, чтобы не писать громоздких и запутанных алгоритмов используют вспомогательные алгоритмы.

Вспомогательный алгоритм – это подпрограмма, которая выполняет какое-то действие, предусмотренное исходным заданием (слайд 2).

Мы создадим два вспомогательных алгоритма:

  1. Построим алгоритм «Забор»
  2. Построим алгоритм «Ель»
  3. Соединим два алгоритма и применим Цикл N раз.

Описание действий, которые могут повторятся указанное число раз или пока не выполнено заданное условие, называется циклом.

При составлении алгоритмов довольно часто встречаются случаи, когда некоторую последовательность команд нужно выполнить несколько раз подряд. Для упрощения записи алгоритма в таких случаях можно использовать специальную конструкцию повторения N раз.

Общий вид цикла:

нц <количество раз> раз
        <тело цикла (последовательность команд)> 
кц  (слайд 4).

2. Проработка содержания темы обучающимися:

Задание: Создать следующий рисунок в программе Кумир, используя исполнитель Чертежник (слайд 3).

Построим алгоритм «Забор» (слайд 5).

алг забор
нач
нц 10 раз
        опустить перо
        сместиться на вектор (0,10)
        сместиться на вектор (2,2)
        сместиться на вектор (2,-2)
        сместиться на вектор (0,-10)
кц
кон

Построим алгоритм «Ель» (слайд 6).

алг ель
нач
нц 5 раз
        опустить перо
        сместиться на вектор (0,15)
        нц 5 раз
                сместиться на вектор (-2,-2)
                поднять перо
                сместиться на вектор (2,0)
                опустить перо
        кц
        нц 5 раз
                поднять перо
                сместиться на вектор (2,0)
                опустить перо
                сместиться на вектор (-2,2)
        кц
        поднять перо
        сместиться на вектор (8,-15)
кц
кон

Запишем основной алгоритм, пользуясь вызовом процедуры вспомогательного алгоритма (соединим два вспомогательных алгоритма).

использовать Чертежник
алг
нач
нц 10 раз
        забор
кц
поднять перо
сместиться на вектор (-36,10)
нц 5 раз
        опустить перо
        ель
кц
кон

алг забор
нач
        опустить перо
        сместиться на вектор (0,10)
        сместиться на вектор (2,2)
        сместиться на вектор (2,-2)
        сместиться на вектор (0,-10)
кон

алг ель
нач
опустить перо
сместиться на вектор (0,15)
нц 5 раз
        сместиться на вектор (-2,-2)
        поднять перо
        сместиться на вектор (2,0)
        опустить перо
кц
нц 5 раз
        поднять перо
        сместиться на вектор (2,0)
        опустить перо
        сместиться на вектор (-2,2)
кц
поднять перо
сместиться на вектор (8,-15)
кон

Дополнительное задание: Создать вспомогательный алгоритм «ДОМ» и дополнить картинку (слайд 7).

4. Домашнее задание: повторить конспект (придумать свои рисунки с применением вспомогательного алгоритма).

25.06.2018